Trunks – Dell Power Connect and Cisco

I recently needed to install a stack of Dell 6224 Power Connect switches. The core of the network was actually a Cisco 3560 (no G). While there are already posts existing from Scott Lowe about using the “General” mode to keep VLAN 1 untagged and also have other VLAN’s tagged. Dell’s General mode traditionally works just like a default dot1q trunk in Cisco. However when VLAN 1 is in use I secretly grumble because I know the fact that Dell’s general mode is finicky when interoperating with some devices. Most of the time general mode works like a charm but not on this day.

Dell’s “trunk” mode worked fine. Any tagged VLAN would pass fine to the Cisco. Except that pesky native VLAN 1. We HAD to have VLAN 1 passed down to the ESX servers. So after kicking around wondering what I did wrong I decided to just work around the problem. I tagged vlan 1 on the Dell port and changed the native vlan on that specific trunk on the Cisco to another vlan (not being used on the Dell). BAM it worked.

Note: Dell was running their newest firmware on that day – (they have since released
Note 2: I am all about auto-negotiation at Gigabit but still like 100Mbps switch links to be hard coded.

Cisco 3560 (no G).

interface FastEthernet 0/24
speed 100
duplex Full
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,11
swtichport trunk native vlan 8
switchport mode trunk

Dell 6224

interface Ethernet 1/g24
no negotiation
speed 100
duplex full
switchport mode trunk
switchport trunk allowed vlan add 1,10,11